NIH | National Cancer Institute | NCI Wiki  

How do I know which version of the NBIA Data Retriever I am running?

For the NBIA Data Retriever version 3.0 and later, the version information appears in the About menu. The version also appears at the bottom of the login windows when you download a private collection. The following steps explain how to find out which version of the NBIA Data Retriever you are running for version 2.0 and earlier in different operating systems.

On Windows 10:

  1. Open the Start menu.
  2. Click Settings > System.
  3. From the left pane, select Apps & features.
  4. Search for NBIA Data Retriever.
  5. Click NBIA Data Retriever and the version number appears in the application details.

    Apps and Features menu in Windows 10 showing NBIA Data Retriever

On Windows 7:

  1. Open the Control Panel.
  2. Click Programs and Features. The version number appears in the version column.

    Uninstall or change a program screen from the Windows 7 Control Panel

On Mac:

  1. Go to the Finder.
  2. Click an application to select it, then press the spacebar. A window appears, showing the version number, size, and last modification date.

    NBIA Data Retriever installed on a Mac

On CentOS:

  • Type the following command at the command prompt of a terminal window: 
    yum list installed | grep "TCIADownloader"

On Ubuntu:

  • Type the following command at the command prompt of a terminal window:  
    dpkg -l |grep tciadownloader

Why does nothing happen after I click Remind me later on the New Version Notification window?

As of TCIA/NBIA 6.5.3, manifest files are self-contained and only version 3.0 and later of the NBIA Data Retriever can read it. Please update your app.

Why, after I upgrade the NBIA Data Retriever, do two versions of it appear in Apps & features on Windows 10, and on Programs and Features on Windows 7?

You can ignore the double entries. It is likely that you installed an early version of NBIA Data Retriever 2.0 or NBIA Data Retriever 1.0,  which have different upgrade codes internally. The old software is removed when the new version is installed. If the newly installed application is not functioning as expected, you can manually remove the old one and reinstall the new one. However, it is not required to do so.

I generated a manifest file a while ago. How do I know which version of the NBIA Data Retriever to use with it?

Always use the latest version of the application. The Downloader application is backward-compatible. The following table shows the version compatibility between manifest files and the Downloader.

NBIA Data Retriever Version

Manifest V1.0

Manifest V2.0

Manifest V3.0

1.0

Working

Working with public data requests*

Not working

2.0

Working with public data requests

Working

Auto-Upgrade and Manual Upgrade are working.

Remind Me Later does nothing.

3.0

Working with public data requests

Working

Working

What is the dependency of the NBIA Data Retriever on Linux and how we can satisfy the dependencies?

On CentOS or Red Hat Linux, use the command sudo yum -v -y remove TCIADownloader.x86_64;sudo yum -y install NBIADataRetriever -3.2-1.x86_64.rpm to install the NBIA Data Retriever. This command pulls and installs all missing dependent libraries when the NBIA Data Retriever is installed. If you install another way, you may not install all of the dependent libraries. Also, note that the NBIA Data Retriever always takes a manifest file as a parameter. In a GUI desktop environment, start the NBIA Data Retriever by clicking a manifest file.

How do I run the NBIA Data Retriever from the command line on RedHat/CentOS Linux?

Assuming the NBIA Data Retriever is installed on /opt/Downloader (this is the location that the NBIA Data Retriever is installed at when it is installed with command sudo yum -v -y remove TCIADownloader.x86_64;sudo yum -y install NBIADataRetriever -3.2-1.x86_64.rpm).  To run the NBIA Data Retriever from the command line, assuming you are running the NBIA Data Retriever 3.2, type the command:

sudo /opt/NBIADataRetriever/NBIADataRetriever  <full path of manifest file including the file name>

The NBIA Data Retriever always needs to run with a manifest file. Although the application can be invoked from command line, it works best in a desktop environment such as Gnome, KDE, and so on. Once the NBIA Data Retriever is installed in the desktop environment, you can click any manifest file with the extension .tcia to invoke the app.

Using the NBIA Data Retriever, I get error messages for “Error invoking method” then “Failed to launch JVM”. How can I fix this problem?

These errors occur because the NBIA Data Retriever cannot work without a manifest file. See Creating Manifest Files for instructions to create a manifest file using NBIA or an API. To avoid this error, download and install the NBIA Data Retriever first, then locate a manifest file on your computer. If you have not installed the Downloader App or TCIA Downloader before, consider removing these applications first before installing the NBIA Data Retriever. This is not mandatory but will prevent you from having to specify which application your computer should use to open the manifest file. To do so, right-click the manifest file and choose to open it with the NBIA Data Retriever. 

I clicked a manifest file and received the error “Failed to find library: jvm.dll” on Windows 10. How can I fix it?

This is a Java bug that displays the following error message:

The workaround is to uninstall the NBIA Data Retriever and download the free community version of Visual Studio 2017. Install Visual Studio 2017 and then reinstall the NBIA Data Retriever.

  • No labels