Notice: This application will enforce Multi-factor authentication (MFA) for NIH users beginning the evening of Wed Aug 3rd.
NIH | National Cancer Institute | NCI Wiki  

Contents of this Page

Help

To ask questions, get assistance or report bugs, contact Application Support.

Introduction

This page details the software dependencies for caDSR Products. Find the product listed in the first column, find the release in the second column, then follow the row across for a list of all dependent software, e.g. Curation Tool 3.2.0.6 depends on caCORE API 3.2, JDK 1.5.0_06, etc.

Blank cells (with three dashes) indicate no product dependency on a technology.

When any one or more of these products are installed on secure servers via https, it will be necessary to install trusted certificates across all servers hosting the consuming products. For example, installing the Object Cart on secure server A and installing CDE Browser on server B requires installing a trusted certificate on server B. In this example, it does not matter if server B is secure or unsecure. When all products are installed on the same server this is not necessary.

Dependencies for Release 4.x

Product

Release

 Release Status

Download

caCORE API

caCORE SDK

Database

Hibernate

Language

Web Container

MVC Framework
Object Cart1.0.4PRODUCTION

4.0

Java 1.8JBoss Wildfly 8.2Uses Struts version 2.5.26 & caCORE SDK 4.5
Object Cart1.0.3REPLACED BY 1.0.4

4.0

Java 1.8JBoss Wildfly 8.2Uses Struts version 2.3.16.3 in caCORE SDK 4.5

Object Cart API

1.0.2.1NOT RELEASED

---

 ---4.5  MySql 5.0.27

---

Java 1.6JBoss 5.1Uses Struts version in caCORE SDK 4.5 with upgrade to Uses Struts version 2.3.16.3.

Object Cart API

1.0.2REPLACED BY 1.0.3

---

---

4.5

MySql 5.0.27

---

Java 1.6JBoss 5.1Uses Struts version in caCORE SDK 4.5

Object Cart API

1.0.1

REPLACED BY 1.0.2

---

---

4.0

MySql 5.0.27

---

Java 1.5.0_10

JBoss 4.0.5

Uses Struts version in caCORE SDK 4.0
caDSR API4.1.8PRODUCTION

4.5Oracle 19c
Java 1.8JBoss Wildfly 8.2Uses Struts version 2.5.26 & caCORE SDK 4.5
caDSR API4.1.2REPLACED BY 4.1.8------4.5Oracle 11g
Java 1.8JBoss Wildfly 8.2Uses Struts version in caCORE SDK 4.5 with upgrade to Uses Struts version 2.3.16.3.
caDSR API4.1.1REPLACED BY 4.1.2------4.5

Oracle 10.2g

3.2.0Java 1.6 JBoss 5.1 Uses Struts version in caCORE SDK 4.5 with upgrade to Uses Struts version 2.3.16.3.
caSDR API4.1REPLACED BY 4.1.1------4.5Oracle 10.2g---

Java 1.6


JBoss 5.1Uses Struts version in caCORE SDK 4.5 with upgrade to Uses Struts version 2.3.16.3.

caDSR API

4.0.0.1

REPLACED BY 4.1

---

---

4.0

Oracle 10.2g

---

Java 1.5.0_10

Java 1.5.0_10

Uses Struts version in caCORE SDK 4.0
caDSR Admin Tool EVS Search4.1PRODUCTION---

EVS 6.3

---

---

---

Java 1.8Tomcat 7 Struts  2.3.16.3
caDSR Admin Tool EVS Search4.0REPLACED BY 4.1 

---

EVS 5.1

 

---

 

---

 

---

Java 1.5.0_10

 
 

Java 1.5.0_10

Struts 1.3.5
caDSR Database and Admin Tool4.2NOT RELEASED

---

---

---

Oracle 11g

---

PL/SQL

Oracle Application Server

Does not use Struts 

caDSR Database and Admin Tool

4.0

PRODUCTION 

---

---

---

Oracle 10.2g
10.2.0.2.0

---

PL/SQL

Oracle Application Server

Does not use Struts 
caDSR Freestyle Search4.1.8PRODUCTION
caDSR API 4.1.8
Oracle 19c
Java 1.8JBoss Wildfly 8.2Struts 1.3.5
caDSR Freestyle Search4.1.2REPLACED BY 4.1.8
caDSR API 4.1.2
Oracle 11g
Java 1.8JBoss Wildfly 8.2Struts 1.3.5
caDSR Freestyle Search4.1

REPLACED BY 4.1.2


---caDSR API 4.1---Oracle 10.2g---Java 1.6JBoss 5.1Struts 1.3.5

caDSR Freestyle Search

4.0

REPLACED BY 4.1

---

caDSR API 4.0.x

---

Oracle 10.2g

---

Java 1.5.0_10

JBoss 4.0.5

Struts 1.3.5
caDSR Sentinel Tool4.0.7PRODUCTION
EVS 6.5
Oracle 19c
Java 1.8JBoss Wildfly 8.2Struts 1.3.5
caDSR Sentinel Tool4.0.4REPLACED BY 4.0.7
EVS 6.3
Oracle 11g
Java 1.8JBoss Wildfly 8.2Struts 1.3.5

caDSR Sentinel Tool

4.0.3REPLACED BY 4.0.4

---

EVS 6.0

---

Oracle 10.2g

---

Java 1.6JBoss 5.1Struts 1.3.5

caDSR Sentinel Tool

4.0.2.1

REPLACED BY 4.0.3

---

EVS 5.1

---

Oracle 10.2g

---

Java 1.5.0_10

JBoss 4.0.5

Struts 1.3.5 
CDE Browser5.3.5PRODUCTION
Object Cart API1.0.3
Oracle 19c
Java 1.8JBoss Wildfly 8.2Does not use Struts or Oracle BC4J
CDE Browser5.2REPLACED BY 5.3.5---Object Cart API1.0.3---Oracle 11g---Java 1.8JBoss Wildfly 8.2Does not use Struts or Oracle BC4J

CDE Browser

4.0.5REPLACED BY 5.2

---

Object Cart API 1.0.2

---

Oracle 10.2g

---

Java 1.5.0_10

JBoss 4.0.5

Struts 1.3.5, Oracle BC4J

Uses caDSR API 4.0 client jar

CDE Browser

4.0.4REPLACED BY 4.0.5

---

Object Cart API 1.0.2

---

Oracle 10.2g

---

Java 1.5.0_10

JBoss 4.0.5

Struts 1.3.5, Oracle BC4J

Uses caDSR API 4.0 client jar

CDE Browser

4.0.3

REPLACED BY 4.0.4

---

Object Cart API 1.0.1

---

Oracle 10.2g

---

Java 1.5.0_10

JBoss 4.0.5

Struts 1.3.5, Oracle BC4J

CDE Curation Tool4.1.8PRODUCTION
EVS 6.5
Oracle 19c
Java 1.8JBoss Wildfly 8.2Does not use Struts
CDE Curation Tool4.1.2REPLACED BY 4.1.8
EVS 6.3
Oracle 11g
Java 1.8JBoss Wildfly 8.2Does not use Struts

CDE Curation Tool

4.1REPLACED

---

EVS 6.0

---

Oracle 10.2g

---

Java 1.6JBoss 5.1Does not use Struts

CDE Curation Tool

4.0.2.1

 REPLACED

---

EVS 5.1

---

Oracle 10.2g

---

Java 1.5.0_10

JBoss 4.0.5

Does not use Struts
Semantic Integration Workbench4.2.2PRODUCTION
EVS 6.5
Oracle 19c
Java 1.8---Does not use Struts
Semantic Integration Workbench4.1.2REPLACED BY 4.2.2---EVS 6.3
Oracle 11g---Java 1.8---Does not use Struts

Semantic Integration Workbench

4.1.1 REPLACED---

EVS 6.0

caDSR API 4.1

---

Oracle 10.2g

---

Java 1.6

---

Does not use Struts

Semantic Integration Workbench

4.0.0.1

REPLACED BY 4.1.1

---

EVS 5.1
caDSR API 4.0.x

XMI_HANDLER_SDK_40_08292007

FreestyleSearch

---

Oracle 10.2g

---

Java 1.5.0_10

---

Does not use Struts
UML Loader4.2.0Command Line Tool


EVS 6.5

caDSR API 4.1

---

Oracle 19c

---

Java 1.8

---

Does not use Struts
UML Loader4.1.1Command Line Tool

---

EVS 6.0

caDSR API 4.1

---

Oracle 10.2g

---

Java 1.6

---

Does not use Struts
UML Loader4.0.0.1REPLACED BY 4.1.1

---

EVS 5.1

caDSR API 4.0.x

---

Oracle 10.2g

---

Java 1.5.0_10

---

Does not use Struts
UML Model Browser4.0.3 DEPRECATED--

caDSR UML Model API 4.0

 4.0Oracle 10.2g

---

Java 1.5.0_10tbdStruts 1.3.5
Form Builder4.1.6PRODUCTION--Object Cart API 1.0.3
Oracle 19c
Java 1.8JBoss Wildfly 8.2

Struts 1.3.5 (FormBuilder)

Struts 2.5.26 (FormLoader)

Form Builder4.1.2REPLACED BY 4.1.6--Object Cart API 1.0.3
Oracle 11g
Java 1.8JBoss Wildfly 8.2Struts 2.x

Form Builder

4.0.3 REPLACED--Object Cart API 1.0.2--Oracle 10.2g (view)--Java 1.5.0_10JBoss 5.1

Struts 1.3.5

Struts 2.x

caDSR Password Change Station1.0.2PRODUCTION------Oracle 19c
Java 1.8JBoss Wildfly 8.2Does not use Struts
caDSR Password Change Station1.2REPLACED------Oracle 11g
Java 1.8JBoss Wildfly 8.2Does not use Struts
caDSR Password Security Station1.0REPLACED------Oracle 10.2g--Java 1.6JBoss 5.1

Does not use Struts


NCI cgMDR-- N/A. MS Excel Plugin.

---

EVS 5.0

caDSR API 4.0.x

---eXist---tbdtbdDoes not use Struts 
Form Builder (New Form Cart)4.1NOT RELEASED

---

Object Cart API 1.0.2

---Oracle 10.2g (view)---tbdtbdStruts 1.3.5
Form Loader4.1NOT RELEASED

---

Object Cart API 1.0.2

---Oracle 10.2g (view)---tbdtbdStruts 2.3.12
Bulk LoadertbdCommand Line TooltbdEVS 5.1tbdtbdtbdtbdtbdDoes not use Struts  
  • No labels