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CHAPTER

1
ACCESSIBILITY QUICK REFERENCE

The following tables list steps technical writers at CBIIT must take to create Section 
508-compliant documents. These steps may overlap with but do not replace the HHS 
checklists for achieving Section 508 compliance.

Table 1.1 explains how to prepare a FrameMaker document for accessibility.

Table 1.1  Steps for Creating Accessible Documents in FrameMaker

Step
Steps for creating accessible documents in 
FrameMaker

For more information, see

1 Design with accessibility in mind. Only use our 
template styles, including character styles for common 
formatting such as bold and italic. Resist overriding 
template styles.

http://www.webaim.org/

2 Use our latest FrameMaker template that consolidates 
all paragraph styles into each file in the book. 

Important note! If you prefer to import styles from the 
new template rather than starting with an empty file, do 
not import styles into the TOC. Use the new TOC 
template file.  

L:\Technical 
Writing\Templates\FrameM
aker Templates\Current FM 
Templates

http://www.webaim.org/
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Creating Accessible Word Documents
Table 1.2 explains how you can prepare your Word documents for accessibility. Note 
that Word documents lose some of the accessibility options you introduce once they 
reach Acrobat. It is likely that you will need to post-process the file in Acrobat.

Note: Refer to wordCheckList‐HHS.pdf and adobeCheatSheatWordToPDFa.pdf for helpful tips.

3 Add alternate text to images. 

1. Place all graphics in anchored frames. 

2. Click an anchored frame one time to select it.

3. Right-click the anchored frame and select 
Object Properties. 

4. Click the Object Attributes button. The Object 
Attributes dialog box appears.

5. In the Alternate box, type an alternate text 
description for the content of the anchored 
frame

6. Click Set and then Set again. A screen reader 
can now read the alternate text.

Adding Alternate Text to 
Images on page 9

4 Use row and column headings and captions for all 
tables. Do not merge table rows or columns. Do not 
allow rows to break across pages.

Using Good Table Manners 
on page 10

5 Use meaningful link anchors rather than URLs when 
possible. Use the Go to URL hypertext marker for all 
URLs in FrameMaker.

Naming Link Anchors on 
page 11

6 In the PDF Setup dialog box, select Generate PDF 
Bookmarks, Generate Tagged PDF (click Default to 
tag all styles), and Create Named Destinations for All 
Paragraphs.

Use the latest book file in the template to inherit 
appropriate bookmark and tag options.

Creating a Tagged PDF 
from FrameMaker on page 
11

Table 1.1  Steps for Creating Accessible Documents in FrameMaker

Step
Steps for creating accessible documents in 
FrameMaker

For more information, see

Table 1.2  Steps for Creating Accessible Documents in Word

Step Steps for creating accessible documents in Word For more information, see

1 Design with accessibility in mind. Only use our 
template styles, including character styles for common 
formatting such as bold and italic. Resist overriding 
template styles.

http://www.webaim.org/

http://www.webaim.org/
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2 Add alternate text to images. 

Word 2003

1. Right-click the image, then select Format 
Picture. The Format Picture dialog box 
appears.

Note: If the Format Picture menu option is not 
available, view the Picture toolbar and click the 
Format Picture button.

2. Select the Web tab and then add the 
appropriate alternative text.

Word 2007

1. Right-click the picture and select Size. The 
Size dialog box appears.

2. Select the Alt Text tab. The image filename is 
entered into the field by default. Delete that 
and enter appropriate alternate text.

Adding Alternate Text to 
Images on page 9

3 Use row and column headings and captions for all 
tables. Do not merge table rows or columns. Do not 
allow rows to break across pages.

Using Good Table Manners 
on page 10

4 Use meaningful link anchors rather than URLs when 
possible. 

Naming Link Anchors on 
page 11

5 Configure PDFMaker to tag the document properly. 

In Word 2003, select Adobe PDF > Change 
Conversion Settings.

 On the Settings tab, select Bookmarks, Links, 
and Enable Accessibility and reflow.

 On the Word tab, select Convert cross 
references, Convert footnote and endnote 
links, and Enable advanced tagging.

 On the Bookmarks tab, select Convert Word 
Headings to Bookmarks and set the proper 
indent levels.

Table 1.2  Steps for Creating Accessible Documents in Word

Step Steps for creating accessible documents in Word For more information, see
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Creating Accessible PDFs
Table 1.3 explains how to create an accessible PDF once your source file is in Acrobat.

Note: Refer to pdfCheckList‐HHS.pdf for helpful tips. 

Table 1.3  Steps for Creating Accessible PDFs in Acrobat 9.x

Step Steps for creating accessible PDFs For more information, see

1 In the document properties, enter NCI CBIIT as the 
Author. In the Keywords field, enter 508 Compliant 
as one of your keywords.

2 Specify document language.

1. Select File > Document Properties.

2. Click the Advanced tab. 

3. In the Language list, select English US 
language.

Characteristics of 
Accessible PDFs on page 
13

3 Use the document structure to prevent errors in the 
accessibility report.

1. Select all pages in the document.

2. Right-click and then select Use Document 
Structure.

4 Run an accessibility full check using the Adobe PDF 
option.

1. Select Advanced > Accessibility > Full 
Check. The Accessibility Full Check dialog box 
appears. 

2. Click Start Checking. 

Using the Adobe Acrobat 
Accessibility Tool on page 
14

5 Fix any problems reported by the accessibility checker. 
Documents from Word tend to have more problems 
than documents from FrameMaker. Documents from 
Word may need post-processing in Acrobat. Use the 
accessibility checker report as a troubleshooting guide 
to narrow down problem areas.

To begin post-processing in Acrobat, select 
Accessibility > TouchUp Reading Order. In the 
TouchUp Reading Order dialog box, click Show order 
panel.

 Confirm that each numbered box in the document 
is properly tagged. 

 Add alternate text as needed to figures as needed.

 Remove nonessential content, such as ornamental 
page borders, from the logical structure tree as 
needed.

 Note that when you remove the tags (such as by 
using the Delete Item Structure or Clear Page 
Structure commands), you cannot undo that action. 
Save your file often.
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Accessibility Testing
Table 1.4 suggests ways you can test your ePublisher, Flare, and PDF output for 
accessibility. 

Table 1.4  Ways to Test Your Output

Ways to Test Your Output For more information, see

Refer to the HHS accessibility checklists

In ePublisher, run the accessibility report. Ignore errors 
about missing long descriptions and table summaries. 
If you use alternate text for graphics and include either 
a text introduction or caption for tables, you’re covered 
on those.

Using the WebWorks ePublisher 
Accessibility Report on page 15

Download the WAVE Firefox toolbar and view the help 
in Text-only view.

http://wave.webaim.org/toolbar

Download an evaluation copy of JAWS and read the 
document out loud.

http://www.freedomscientific.com/
products/fs/jaws-product-page.asp

Use the Adobe Read Out Loud feature to simulate what 
it would be like for other assistive technology (such as 
JAWS) to read your PDFs out loud.

Turn off your monitor when you use either JAWS or 
Adobe Read Out Loud (this takes some practice with 
each tool) to simulate what it is like not to see what you 
are doing.

Tab through the output to make sure that the reading 
order is logical.

http://wave.webaim.org/toolbar
http://www.freedomscientific.com/products/fs/jaws-product-page.asp
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CHAPTER

2
DEVELOPING ACCESSIBLE DOCUMENTS

This guide is intended to help the technical documentation team at CBIIT design and 
deliver documents that are fully compliant with Section 508 of the Rehabilitation Act of 
1973. Not only is this mandatory of all Federal agencies including the National Cancer 
Institute but accessible documents may result in better structured documents, which 
can only help us as our documentation processes evolve. Accessible documents also 
provide text-only alternatives for graphics, which will help those with slower web 
connections.

This document includes the following sections:

 About Section 508 on this page

 Creating Accessible Documents at CBIIT on page 8

 Checking Documents for Accessibility on page 13

About Section 508

For background on this Federal regulation, read the following from http://
www.section508.gov:

In 1998, Congress amended the Rehabilitation Act to require Federal agencies 
to make their electronic and information technology accessible to people with 
disabilities. Inaccessible technology interferes with an individual's ability to 
obtain and use information quickly and easily. Section 508 was enacted to 
eliminate barriers in information technology, to make available new 
opportunities for people with disabilities, and to encourage development of 
technologies that will help achieve these goals. 

The law applies to all Federal agencies when they develop, procure, maintain, 
or use electronic and information technology. Under Section 508 (29 U.S.C. ‘ 
794d), agencies must give disabled employees and members of the public 
access to information that is comparable to the access available to others.

http://www.section508.gov
http://www.section508.gov
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The Web Content Accessibility Guidelines provide an international set of guidelines. 
The Worldwide Web Consortium (W3C), the governing body of the web, developed 
them. These guidelines are the basis of most web accessibility law in the world. The 
latest version of these guidelines, 2.0, requires that websites adhere to the following 
four principles:

 Perceivable: Available to the senses (vision and hearing primarily) either 
through the browser or through assistive technologies (e.g. screen readers, 
screen enlargers, etc.)

 Operable: Users can interact with all controls and interactive elements using 
either the mouse, keyboard, or an assistive device.

 Understandable: Content is clear and limits confusion and ambiguity.

 Robust: A wide range of technologies (including old and new user agents and 
assistive technologies) can access the content.

At CBIIT, we can design our documentation to address most of these principles. The 
tools we use can do the rest.

Creating Accessible Documents at CBIIT

To make our documents compliant with Section 508 of the Rehabilitation Act, we must 
prepare our source files and then test our output files. The tools we currently use to 
create our source files, Adobe FrameMaker and Microsoft Word, both allow us to 
prepare for accessibility. 

Our output files are currently in PDF and ePublisher WebHelp 5.0 formats. The tools 
we currently use to create those files, Adobe Acrobat 9 and WebWorks ePublisher Pro 
9.2, contain tools of their own that check for how well files conform to the Section 508 
accessibility standards. We can run those checks to see if we need to make any 
additional tweaks to our source files. We should avoid as much post-processing to 
output files as we can.

Most of our preparations for accessibility should be done in the source files. This 
document explains how to prepare a FrameMaker document for accessibility and links 
to procedures where you can accomplish the same goals in Word. 

This section includes the following topics:

 Preparing FrameMaker Files For Accessibility on page 9

 Preparing Word Files For Accessibility on page 12

 Characteristics of Accessible PDFs on page 13

 Checking Documents for Accessibility on page 13

 Using the WebWorks ePublisher Accessibility Report on page 15

http://www.w3.org/TR/WCAG20/
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Preparing FrameMaker Files For Accessibility
See the following sections to learn how to prepare your FrameMaker files for 
accessibility. 

 Adding Alternate Text to Images on page 9

 Using Good Table Manners on page 10

 Naming Link Anchors on page 11

 Creating a Tagged PDF from FrameMaker on page 11

 The Problem with Automated Tools on page 14

 Accessibility Tools Need Human Judgment on page 14

 Using the Adobe Acrobat Accessibility Tool on page 14

Adding Alternate Text to Images
Alternate (alt) text is typically used for describing an image so that screen readers can 
read it aloud. 

FrameMaker limits alternate text to 255 characters.

To add an alternate text descriptions to an image

1. Place all graphics in anchored frames. 

2. Click an anchored frame one time to select it.

3. Right-click the anchored frame and select Object Properties. 

4. Click the Object Attributes button. The Object Attributes dialog box appears.

5. In the Alternate box, type an alternate text description for the content of the 
anchored frame.  

Figure 2.1 Sample alternate text for a screen shot.

Note: Actual text is for reading aloud the actual text, as in the case of a drop 
cap. For example, if the author is using a drop cap for the letter A in the 
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word ʺAdobeʺ but still wants the screen readers to read the word as 
ʺAdobeʺ and not as ʺdobe,ʺ this can be done by filling in actual text. 

6. Click Set and then Set again. A screen reader can now read the alternate text.

Using Good Table Manners
Section 508 differentiates between data tables and tables used purely for layout 
purposes, which it calls layout tables. A layout table would not have a table header. 
Most of our tables at CBIIT are data tables. 

Section 508 specifies that we must do the following to create accessible data tables:

 Designate row and column headers using the <th> tag.

 Associate the data cells with appropriate headers.

 Use proportional sizing, rather than absolute sizing.

 Provide names or titles for data tables using the <caption> tag.

 Provide summaries using the summary attribute.

 Avoid spanned rows or columns.

 Avoid tables with more than two levels of row and/or column headers.

See http://www.webaim.org/techniques/tables/data.php for more information about 
each of these characteristics of accessible data tables.

Since we are not working in raw HTML we do not have the opportunity to control all of 
these characteristics.

Our current ePublisher stationery uses proportional sizing for all of our table styles.

FrameMaker does apparently support a marker called TableSummary, which you can 
insert anywhere in a table, with the content of that marker being a summary of the 
table’s content. However, it doesn’t appear that these summaries are converted 
correctly into PDF or web-based help, since both the Acrobat and ePublisher 
accessibility checkers continue to note the absence of table summaries in documents I 
have tested.

Our best bet is to use row and column headers where appropriate and include table 
captions for every table. We can write our table captions to accurately describe the 
content of the table. When that is not practical, it might be best to introduce a table with 
a summary of it.

We do not currently produce output for table or figure captions in the help we create 
with ePublisher. We can either change that practice or make sure to summarize a table 
when we introduce it, even in help output.

http://www.webaim.org/techniques/tables/data.php
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Naming Link Anchors
Most tips regarding the accessibility of links concern proper coding of them so that all 
users can tab between them using a keyboard. Links also need to have a unique 
appearance so that they can always be identified as links. Our tools take care of both of 
these things.

Since we do not code our own links but rather use FrameMaker or ePublisher to create 
them, we should focus on the following.

 Links should make sense out of context. When using human readable link 
anchors (as opposed to URLs), we should avoid non-informative link phrases 
such as "click here," "more," "click for details," as these are almost completely 
meaningless when read out of context. 

 URLs used as links are fine when they are short. The key is to be considerate of 
screen reader users who must listen to the longer, less intelligible URLs. Human 
readable link anchors are better than long URLs.

It is also a good general practice to introduce any link by describing the advantage that 
will be gained by following it.

Creating a Tagged PDF from FrameMaker
Tagged PDF files contain a document's logical structure and metadata, and are the 
most reliable format for the following:

 Use with a screen reader

 Correct reflow of content into various size devices such as PDAs

 Recognition of alternative text descriptions for graphics

PDF tags exist for accessibility purposes only and have no visible effect on the PDF file.

To set up a tagged PDF

1. Click File > Print or File > Print Book. Select Adobe PDF as your printer.

2. Select the Generate Acrobat Data option and then click the PDF Setup button. 
The PDF Setup dialog box appears.

3. Click the Tags tab. Select the Generate Tagged PDF option and then do the 
following:

a. Move paragraph tag names to the Include Paragraphs list to indicate 
paragraphs you want included in the PDF logical structure.
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b. Select a paragraph tag name and then use the arrows located directly under 
that list to indicate the structure level of the selected paragraph (see 
Figure 2.2).

Figure 2.2 Tagged PDF requires that you define the logical structure of a document.

c. Click Set.

Preparing Word Files For Accessibility
Microsoft Word also contains the tools necessary to create accessible documents. 
Perhaps the most important contributing factor to an accessible Word document is the 
use of Word styles. Properly structured documents that do not use override styles but 
rather styles defined by a template are the easiest for a screen reader to follow.

Accessibility Quick Reference on page 1 also includes some tips for adding alternate 
text and creating a tagged PDF.

For detailed information about creating accessible Word files, see 
http://www.webaim.org/techniques/word/. You can also find detailed information in the 
online help for Adobe Acrobat.

http://www.webaim.org/techniques/word/
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Characteristics of Accessible PDFs
Adobe defines accessible PDFs as having the characteristics in the table below. The 
table also presents an interpretation of how each characteristic applies to the technical 
documentation team at CBIIT.

Checking Documents for Accessibility
Both ePublisher and Acrobat contain accessibility tools that help spot glaring 
accessibility errors and remind us of accessibility issues that require manual checks. 
Using accessibility tools like these is really just one of the first steps toward Web 
accessibility.

Other accessibility tools are available for free on the web, though this document does 
not review them. See http://www.webaim.org/articles/freetools/compare.php for a full 
review of free, online accessibility tools.

Credit for the content of the following two sections goes to WebAIM (http://
www.webaim.org/articles/freetools/).

Characteristic of 
Accessible PDFs

How This Applies To CBIIT

Searchable text Do not scan documents to create a PDF. This converts all text to 
an image that a screen reader cannot scan.

Fonts that allow 
characters to be extracted 
to text

Make sure we only use fonts that can be extracted to Unicode 
characters.

Note: Maybe this is the problem the Accessibility Checker has 
with our bullet font?

Interactive form fields We do not use form fields.

Other interactive features: 
buttons, hyperlinks, and 
navigational aids

We already use links, bookmarks, headings, and a TOC, so we 
are covered here. 

Document language We cannot specify the document language from FrameMaker or 
Word so we must do so in the final PDF. To specify the document 
language, do the following. 

1. Select File > Document Properties.

2. Click the Advanced tab. 

3. In the Language list, select English US language.

Security that will not 
interfere with assistive 
technology

We should not set any security restrictions on our PDF files. We 
do not currently do so. The text of an accessible PDF must be 
available to a screen reader.

Document structure tags 
and proper read order

When we create a tagged PDF, the structure of our source 
document creates the appropriate document structure tags. 
However, it appears that not all elements in our source files result 
in correctly structured tags. The Acrobat Accessibility Checker 
identifies these tags and it will be a learning process for all of us 
how many tags we need to fix.

Alternative text 
descriptions

We will start to do this in our source files.

Table 2.1  Characteristics of Accessible PDFs and How They Affect Us at CBIIT

http://www.webaim.org/articles/freetools/compare.php
http://www.webaim.org/articles/freetools/
http://www.webaim.org/articles/freetools/
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The Problem with Automated Tools
In the same ways in which we don't always accept the results of a spell and grammar 
check (or they don't catch the real errors we have because words are spelled correctly), 
web accessibility requires more than just accessibility tools; it requires human 
judgment. All accessibility tools vary slightly in their interpretation of WCAG 1.0 and 
Section 508, and depending on the interpretation, accessibility tools can give users 
some automated results that require human judgment.

Here is an example. WCAG 1.0 Priority 3 checkpoint 5.5 states, "Provide summaries 
for tables." Interpreted strictly, this checkpoint could mean, every table in a web page 
should have a summary attribute. In practice, putting summary attributes into both data 
tables (which should have summaries) and layout tables (which do not need them) just 
gives individuals using screen readers more distracting information to read through.

Accessibility Tools Need Human Judgment
It is important to remember that accessibility tools can only partially check accessibility 
through automation. Of the sixteen standards in Section 508, only seven standards can 
be partially evaluated automatically. Similarly, of the combined 65 checkpoints in 
WCAG 1.0 Priority 1 through Priority 3, only nineteen can be partially evaluated 
automatically. The real key is to learn and understand the web accessibility standards 
rather than relying on a tool to determine if a page is accessible or not.

Using the Adobe Acrobat Accessibility Tool
Creating a tagged PDF with alt-text specified for each graphic from FrameMaker or 
Word is the first step in creating a truly accessible PDF file. We must also post process 
the PDF file to complete that process.

To prepare a PDF for an accessibility check, do the following.

1. Specify the document language as explained in Table 2.1.

2. Run the Adobe Acrobat Accessibility Full Check, as follows.
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a. Select Advanced > Accessibility > Full Check.The Accessibility Full 
Check dialog box appears. 

b. Accept the default options, which include the Adobe PDF checking option.

c. Click Start Checking. In the resulting report, follow the instructions Acrobat 
provides for finding and correcting accessibility errors.

Note: Some of these accessibility errors require post‐processing of our PDFs. 
Files originating in Word tend to have more accessibility errors that 
result in post‐processing than do those files originating in FrameMaker.

Our goal is to have no accessibility errors and to see the following message 
box:

Using the WebWorks ePublisher Accessibility Report
You can use the WebWorks ePublisher Accessibility report to identify accessibility 
warnings or errors in your online help files.



Creating Accessible Documents at CBIIT

16

To view the accessibility report, do the following.

1. Generate your ePublisher project.

2. In the Document Manager panel in the upper left, click the project name such as 
caBIO Portlet Online Help. Items appear in the Output Explorer below.

3. In the Reports folder, which should already be open, double-click Accessibility 
Report.The content of the report appears to the right. 

Note: The accessibility errors and warnings that appear in this report are 
determined by the settings specified in the Format Settings dialog box 
(Format > Format Settings). The format settings in our current stationery 
are as follows, though a future version of our stationery may not 
generate warnings for images without long descriptions and tables 
without summaries, since those features do not seem to carry over from 
FrameMaker, and have alternatives.

4. If you are missing any alternate text for your images, add it to your source files,  
generate your ePublisher project, and view the accessibility report to confirm 
that you have made your project as accessible as possible.
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