Notice: This application will enforce Multi-factor authentication (MFA) for NIH users beginning the evening of Wed Aug 3rd.
NIH | National Cancer Institute | NCI Wiki  

If you already have LexEVS 6.0 installed, fixes are now available:

6.0.4 Notes
Contains a list of the fixes and functions included in this release.

6.0.4 lbRuntime.jar
If you have started with the LexEVS 6.0.4 Installer GUI then you do not need to use this file. It is already there. If you have LexEVS 6.0 or a later version installed then you can upgrade to 6.0.4. Download this file and overwrite a file by the same name in the {LEXEVS_HOME}/runtime directory. 6.0.4 contains all previous patch releases as well. There is no need to install them first.