NIH | National Cancer Institute | NCI Wiki  

WIKI MAINTENANCE NOTICE

Please be advised that NCI Wiki will be undergoing maintenance Monday, July 22nd between 1700 ET and 1800 ET and will be unavailable during this period.
Please ensure all work is saved before said time.

If you have any questions or concerns, please contact the CBIIT Atlassian Management Team.

Required Software - Not Included in LexEVS

You must download and install required software which is not included with the LexEVS distribution.

Where you have more than one choice you simply need to decide which one product you would like to use with your deployment of LexEVS.

Supported versions of other related technologies can be found listed in the NCI CBIIT Technology Stack pages. Differences between the LexEVS supported software and the NCI CBIIT Technology Stack are negotiated by the LexEVS development team with NCI.

Required Software for LexEVS

An X character marks software that is required while NA means not applicable.

Software Type

Supported

Local Runtime

Distributed

CTS2 ServiceURI Resolver

OS

CentOS release 7.0
Windows 10

Mac OSX 10.x

X

X

XX

Java runtime

Java version 1.8

X

X

XX

Database (1)

MySQL 5.7 (LexEVS 6.5)

X

X

NAX

Database Driver (2)

Mysql driver mysql-connector 5.1.6

X

X

XX

Container

Apache Tomcat 8.5
Apache Tomcat 8.5 (6.1 URI Resolver, CTS2 Service)

NA

X

XX

(1) MySQL 5.7 is the supported and preferred database for LexEVS 6.5.  MySQL 5.7 has been used during the development and in the testing of LexEVS 6.5 MySQL 5.7 is also being used in a production environment for LexEVS 6.5.  While the other databases may work for LexEVS 6.5, they have not been tested.

(2) The MySQL database driver can not be included with LexEVS distributions.